Курс 2016 года “Разработка на UMI.CMS от 0 до готового сайта”
jQuery slideshow - как правильно прикрутить (tpl)

Автор regulaРаздел JS и AJAX

Ответов: 11
Просмотров: 3926
Последний ответ 05 Марта 2013, 10:23:04
от admin
Подгрузка цены с помощью JQuery

Автор albionРаздел JS и AJAX

Ответов: 7
Просмотров: 976
Последний ответ 08 Июля 2015, 15:06:02
от admin
Обновление юми и проблемы с jQuery

Автор ArmorРаздел Настройка системы и модулей

Ответов: 2
Просмотров: 1873
Последний ответ 21 Октября 2011, 00:25:27
от Armor
jQuery код не работает

Автор diii3Раздел Шаблоны XSLT

Ответов: 4
Просмотров: 2177
Последний ответ 18 Марта 2012, 14:56:33
от diii3
According menu Using jQuery

Автор johnРаздел JS и AJAX

Ответов: 1
Просмотров: 2801
Последний ответ 17 Апреля 2012, 23:46:54
от BaceH

0 Пользователей и 1 Гость просматривают эту тему.

*

alex

  • **
  • 59
  • +0/-0
    • Просмотр профиля
    • Сергеев Александр Сергеевич
JQUERY UMI КАРУСЕЛЬ
« : 11 Мая 2011, 18:13:53 »
https://github.com/bkosborne/jQuery-Waterwheel-Carousel
отсюда качаю карусель...она пашет...НО! панелька админская наверху пропадает...
методом исключения выяснил, что конфликтуют строки

<xsl:value-of select="document('udata://system/includeQuickEditJs')/udata" disable-output-escaping="yes" />
и
<script type="text/javascript" src="/js/jquery.waterwheelCarousel-1.2.2.js"></script>

причем, карусельку что в uncompressed, что в min вариантах пробывал - одно и тоже...
конфликтуют..

как узнать в чем? может плагин для ФФ какой, типа firebug'a,только специально для JS? или в карусели что исправить..?

*

admin

  • *****
  • 2416
  • +171/-1
    • Просмотр профиля
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #1 : 11 Мая 2011, 19:48:05 »
firebug покажет в чем конфликт, открой панель firebug и при загрузке страницы выдаст ошибку, во вкладке "консоль"

*

alex

  • **
  • 59
  • +0/-0
    • Просмотр профиля
    • Сергеев Александр Сергеевич
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #2 : 11 Мая 2011, 20:16:47 »
edit in place кажется папка называется, она из яваскриптов...
так вот, там файл compiled.js

и вот что пишет файр:

jQuery.cookie is not a function http://localhost/js/client/edit-in-place/compiled.js Line 1

пробывал вручную <script type="text/javascript" src="/js/jquery/jquery.cookie.js"></script> но тогда еще ошибки выдает...что ж делать?

*

admin

  • *****
  • 2416
  • +171/-1
    • Просмотр профиля
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #3 : 11 Мая 2011, 20:27:20 »
у меня такая проблема возникала когда я подключал jquery отличный от того, который идет в комплекте umi. сегодня подключу его у себя гляну, скинь мне шаблоны по которым ты выводишь картинки для галереи

*

alex

  • **
  • 59
  • +0/-0
    • Просмотр профиля
    • Сергеев Александр Сергеевич
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #4 : 11 Мая 2011, 20:40:10 »
итак...

jquery-1.4.4.min.js шел в комплекте к галерее, без него не пашет галерея. но он вместе с system/includeQuickEditJs не конфликтует.
однако без него галерея не пашет (из этого следует, что стандартная версия jquery пониже этой..)
еще вот что заметил, если system/includeQuickEditJs подключать в шаблоне после jquery.waterwheelCarousel-1.2.2.js (или ее MIN версии), то пашет меню админа, но галерея корявая, наоборот - пашет галерея ,но уже без меню..

отсюда и сделал выводы.

<div id="waterwheel-carousel-default">
<div class="carousel-controls">
    <div class="carousel-prev"><a href="#">&lt;</a></div>
    <div class="carousel-next"><a href="#">&gt;</a></div>
</div>
<div class="carousel-images">
    <xsl:apply-templates select="document(concat('udata://photoalbum/album/',/result/page/@alt-name,'/'))/udata/items" />
</div>
</div>
<xsl:template match="item">
    <xsl:apply-templates select="document(concat('upage://',@id))/udata/page" mode="photo_list" />
</xsl:template>
<xsl:template match="page" mode="photo_list">
</xsl:template>
про последние 2 строчки не спрашивай, они в post.xsl, но они не обрабатываются, работает код который в album.xsl (ниже), но если эти две строчки убрать, то ошибки выдает..короче я не стал разбираться.
вот ниже album.xsl фрагмент
<xsl:template match="page" mode="photo_list">
<a href="{@link}" umi:element-id="{@id}" umi:field-name="photo">
<xsl:call-template name="catalog-thumbnail">
<xsl:with-param name="element-id" select="@id" />
<xsl:with-param name="field-name">photo</xsl:with-param>
<xsl:with-param name="width">440</xsl:with-param>
<xsl:with-param name="height">320</xsl:with-param>
</xsl:call-template>
</a>

</xsl:template>
еще вставлять пытался <xsl:with-param name="crop">2</xsl:with-param> (0,1,2 -разные пробывал) - бестолку, call-template name="catalog-thumbnail" никак мой параметр "вырезать или сжимать" не видит.

собственно все,что касается вывода...

но тут конфликт JQUERY ведь?...мне кажется дело не в версии jquery,а именно в скрипте галереи, который както пересекает скрипт меню...но firebug говорит мне про cookie, которые я кроме как к меню не могу привязать..
« Последнее редактирование: 11 Мая 2011, 20:42:32 от alex »

*

alex

  • **
  • 59
  • +0/-0
    • Просмотр профиля
    • Сергеев Александр Сергеевич
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #5 : 12 Мая 2011, 15:27:11 »
мысли есть?

*

admin

  • *****
  • 2416
  • +171/-1
    • Просмотр профиля
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #6 : 12 Мая 2011, 18:45:22 »
конфликт именно в jQuery библиотеке, по крайней мере пока я не попробую что-то другое, предположить не могу

*

alex

  • **
  • 59
  • +0/-0
    • Просмотр профиля
    • Сергеев Александр Сергеевич
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #7 : 12 Мая 2011, 20:36:43 »
Странно...ведь UMI сама по себе что с 1.4.4 что со стандартной работает на ура...

а вот когда в работающую на 1.4.4 ЮМИ подключаю скрипт галереи, меню вырубается...
можешь какнибудь глянуть сам скрипт галереи? он небольшой,но ошибок я не могу найти..


кстати дело в самой библиотеке быть может потому, что ошику firebug про jquery.cookie пишет, да?

*

talanter

  • *
  • 17
  • +0/-0
    • Просмотр профиля
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #8 : 11 Июня 2011, 03:55:12 »
Как не банально но решение нашлось, тоже сутки или двое искал решение данной проблемы
перепробовал кучу разных lightbox  подобных плагинов но не работал выяснил причину
что конфликтует не EditInPlace а
%system includeQuickEditJs()%
это конфликт использования переменной $

вот решение на самой jquery
http://docs.jquery.com/Using_jQuery_with_Other_Libraries

с тех пор как юми отказалось от prototype ошибка всеравно присуствует.

вот решение
по умолчанию плагин имеет первую строчку
$(document).ready(function(){ -         нужно заменить $ на jQuery и  function($)
<script>
jQuery(document).ready(function($){
//Examples of how to assign the ColorBox event to elements 

$(".calls").colorbox({width:"50%", inline:true, href:"#callnum"});
$(".callsmen").colorbox({width:"50%", inline:true, href:"#callmen"});
});
</script>   

Надеюсь кому поможет это решение.

*

admin

  • *****
  • 2416
  • +171/-1
    • Просмотр профиля
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #9 : 11 Июня 2011, 06:44:03 »
надо будет попробовать, только бы вспомнить на каком сайте такое было)

JQUERY UMI КАРУСЕЛЬ
« Ответ #10 : 02 Ноября 2011, 10:27:30 »
Я конечно, прошу прощения, но не могли бы Вы дать немного больше информации.

*

admin

  • *****
  • 2416
  • +171/-1
    • Просмотр профиля
Re:JQUERY UMI КАРУСЕЛЬ
« Ответ #11 : 02 Ноября 2011, 11:49:07 »
про что подробнее рассказать?