Курс 2016 года “Разработка на UMI.CMS от 0 до готового сайта”
Непонятная проблема с выводом разделов каталога

Автор DZHETIGAPAРаздел Шаблоны XSLT

Ответов: 2
Просмотров: 1539
Последний ответ 06 Декабрь 2011, 14:10:35
от DZHETIGAPA
Проблема вывода каталога и корзины в mobile

Автор SumrakrndРаздел Шаблоны XSLT

Ответов: 9
Просмотров: 416
Последний ответ 16 Август 2016, 15:16:17
от Sumrakrnd
Проблема с подключением к базе данных

Автор don_basilioРаздел Установка UMI.CMS

Ответов: 10
Просмотров: 8095
Последний ответ 03 Ноябрь 2011, 21:00:40
от don_basilio
Проблема с выборкой через usel

Автор shotoРаздел Шаблоны XSLT

Ответов: 6
Просмотров: 508
Последний ответ 11 Февраль 2016, 12:56:37
от crazygeorgio
Проблема вывода даты из order

Автор SumrakrndРаздел Шаблоны XSLT

Ответов: 9
Просмотров: 513
Последний ответ 19 Апрель 2016, 12:46:22
от aghigay

0 Пользователей и 1 Гость просматривают эту тему.

*

A

  • *
  • 7
  • +0/-0
    • Просмотр профиля
Внимание спойлер:
Все проблемы были из за криворукости автора и его незнания.
Не повторяйте его ошибок и копируйте файлы через интернет в tar архивах чтобы ничего не побить и не потерять во время переноса.

-----------------------------------------------------------------------------------------
Добрый день.
Не нашел решения своей проблемы.
Я нуб, не судите строго.

Лицензия Pro Business
В сайте есть алиасы на 2 других (все находится в одной папке и 3 сайта используют один код)

Промучился 10 часов, в итоге все бросил и начал устанавливать заново. Скриптом не пользовался ( -1- битая ссылка на форуме; -2- надеюсь и без него получится)

Скопировал все файлы (scp), сделал дамп БД через pma. При импорте БД через возникли ошибки, но решение нашел на wiki в которой объяснено что в дамп в этом случае нужно добавить три строки. Импорт прошел с ними успешно. В mysql.php все ссылается на localhost, пароли и логины совпадают с созданным юзером БД. БД есть, файлы есть, главная страница вместо приглашения ввести ключ выдает:
"Добро пожаловать!
Сервер запущен и готов к установке UMI.CMS

Вы только что установили UMI.CMS Localhost Pack.
Сервер работает, значит вы можете начать установку UMI.CMS

Вам понадобятся MySQL параметры во время установки.
Мы уже настроили базу данных, чтобы сэкономить Ваше время.
Используйте эти параметры:

* Хост: localhost
* Логин: umi
* Пароль: umi
* Имя базы данных: umi

Удачи!"
___________________
1) Ссылка на установку ведет на localhost/install.php а не на site.ru/install.php

2) У меня Моя созданная база отличается от предлагаемой umi и все это указано в mysql.php

3) Главное--- При переходе на site.ru/install.php на 2ом шаги:"
Ошибка #104

Установка уже завершена
"

---====---
Немножко не в тему, о 10 часах ранее:
---===---
1) При первом переноси UMI любезно выдала предложение ввести ключ, но нажатие на кнопку не приводило ни к каким действиям. Но на сервере появлялся новый файл cache/registry
Следовал согласно статье в wiki но ничего не помогло. Хотя в тот момент я еще не знал как правильно импортировать БД и дружно было решено забить на ошибку.
А также отсутствовал модуль PHP XSL. (понял когда перестанавливал)

2) Решил переустановить UMI согласно wiki прям на новом хосте. Выдало ошибку на отсутствие модуля PHP XSL
После добавления модуля переустановка прошла успешно. Имея разблокированную рабочую UMI я ни смог перезаписать ей сайт так как мало опыта. Далее я решил снести все и начать заного.
« Последнее редактирование: 03 Апрель 2011, 04:41:19 от Anonimus »

*

A

  • *
  • 7
  • +0/-0
    • Просмотр профиля
Re:Проблема переноса с хостинга на хостинг
« Ответ #1 : 02 Апрель 2011, 14:52:57 »
Служба заботы подсказала, что дело в неправильно скопированных файлах. И они были правы, так как я не знал до этого, что "cp" не копирует скрытые файлы >_<

Сейчас вышло сообщение о необходимости Zend Optimizer... В случае удачи, отпишусь.

*

admin

  • *****
  • 2421
  • +172/-1
    • Просмотр профиля
Re:Проблема переноса с хостинга на хостинг
« Ответ #2 : 02 Апрель 2011, 15:40:41 »
а какую версию переносите? и с какого хостинга на какой?

*

A

  • *
  • 7
  • +0/-0
    • Просмотр профиля
Re:Проблема переноса с хостинга на хостинг
« Ответ #3 : 02 Апрель 2011, 16:31:25 »
>а какую версию переносите? и с какого хостинга на какой?
 С хостинга R01.ru на hetzner.de
Сейчас постараюсь найти точную версию umi но знаю пока, что версия 2.7.*



Сейчас ситуация вернулась на свое первоначальную проблему.

Захожу на http://site.ru в вожу ключ, нажимая "проверить ключ" и ничего не происходит... Страница ни как не реагирует  на нажатие кнопки.

Редирект в .htacces убран и захожу без www
сhmod -R 755 cache
chmod -R 755 errors
В БД база cms3_domains содержит site.ru
Версия UMI 2.7.* так что config.ini отсутствует.
В службе заботы сказали, что ключ отвязан и можно регистрировать.
cache/engine имеет 0 размер
cache/registry удаляю перед каждой попыткой

*

A

  • *
  • 7
  • +0/-0
    • Просмотр профиля
Re:Проблема переноса с хостинга на хостинг
« Ответ #4 : 02 Апрель 2011, 19:40:15 »
Версию UMI я так и не нашел где смотреть.

Хотел бы только обратить внимание, что почему то, если я сейчас начну переустанавливать UMI он прекрасно схавает ключ
Если есть какие либо предположения, я готов уже к любым экспериментам, так как я уже в тупике. -)

*

admin

  • *****
  • 2421
  • +172/-1
    • Просмотр профиля
Re:Проблема переноса с хостинга на хостинг
« Ответ #5 : 02 Апрель 2011, 20:54:39 »
версию можно посмотреть в модуле автообновления, сейчас нет времени детально вам помочь, постараюсь вечером ответить чего нибудь полезного

*

A

  • *
  • 7
  • +0/-0
    • Просмотр профиля
Re:Проблема переноса с хостинга на хостинг
« Ответ #6 : 02 Апрель 2011, 22:07:41 »
версию можно посмотреть в модуле автообновления, сейчас нет времени детально вам помочь, постараюсь вечером ответить чего нибудь полезного

Congratulation!!!

Большое спасибо за инициативу помочь.
Действительно и в этот раз ошибка была из за переноса и моей не опытности.

Ранее я все это переносил с хоста командой
scp -r login@site.ru:/httpdocs ./
или через FileZilla

После рекомендации перенести все файлы заново но теперь через tar архив, все заработало.
« Последнее редактирование: 02 Апрель 2011, 22:21:09 от Anonimus »

*

A

  • *
  • 7
  • +0/-0
    • Просмотр профиля
Так же, для полноты информации оставлю тут еще из один ответов адресованный мне.
Цитировать
Все же это ошибки при переносе. Если у вас зазендованные файлы, может, они побились?

В конце-концов. Установите ЮМИ с нуля. Если нет той же версии, попросить в СЗ старый дистрибутив. (Если в папке classes много разных подпапок - это 2.7 и ниже, если только 2 - то 2.8 ). Убедитесь, что чистая установка работает и не имеет ошибок.

Затем залейте базу с данными (либо при установке укажите другую БД, а потом в mysql.php измените параметры), перепишите шаблоны дизайна и кастомные классы (__custom.php в каждой папке модуля и permissins.custom.php, если такое есть), стили, скрипты... в общем, чтобы системные файлы остались чистые, а скопировать только файлы, созданные разработчиками сайта.

Если они не меняли системный код, то этого должно быть достаточно. (А если код зазендован, то они и не могли его менять)

*

admin

  • *****
  • 2421
  • +172/-1
    • Просмотр профиля
я вас правильно понимаю, что в итоге всех телодвижений все получилось?

*

A

  • *
  • 7
  • +0/-0
    • Просмотр профиля
Да. Все получилось. Проблема была в криво перенесенных файлах. После переноса в tar, все заработало.

Когда у меня выскакиволо предложение к инсталяции UMI - я оплошол с командой "cp" не перенеся скрытые файлы на подобие .htaccess

Когда у меня кнопка "проверить ключ" не реагировала на нажатия - Незнаю какие файлы отсутствовавили или повреждены, но tar все решил.
« Последнее редактирование: 04 Апрель 2011, 10:45:10 от Anonimus »

*

admin

  • *****
  • 2421
  • +172/-1
    • Просмотр профиля
Прекрасно)