Курс 2016 года “Разработка на UMI.CMS от 0 до готового сайта”
Как отсортировать баннеры

Автор droidРаздел Шаблоны XSLT

Ответов: 3
Просмотров: 1349
Последний ответ 04 Декабря 2012, 07:20:06
от droid

0 Пользователей и 1 Гость просматривают эту тему.

*

Cubes

  • *
  • 13
  • +0/-0
    • Просмотр профиля
Не добавляются баннеры
« : 25 Февраля 2015, 17:49:47 »
Дошло дело до создания баннеров.
Захожу в модуль - "Баннеры", жму кнопку "добавить баннер", задаю необходимые данные на странице, жму "добавить", далее страница обновляется, но баннера в списке нет. Что делать? Где копать?)

Еще вопрос про расположение баннера в шаблоне (в модуле есть специальная вкладка). Я правильно понимаю, что мы ручками задаем идентификатор, а после указываем его в нужном месте в шаблоне определенной страницы в макросе %banners insert('идентификатор')% ?

*

ilyar

  • ***
  • 128
  • +28/-0
  • UMI.CMS, Yii, Vagrant, BEM
    • Просмотр профиля
    • ilyar на toster
Re:Не добавляются баннеры
« Ответ #1 : 25 Февраля 2015, 18:26:29 »
Дошло дело до создания баннеров.
Захожу в модуль - "Баннеры", жму кнопку "добавить баннер", задаю необходимые данные на странице, жму "добавить", далее страница обновляется, но баннера в списке нет. Что делать? Где копать?)

Еще вопрос про расположение баннера в шаблоне (в модуле есть специальная вкладка). Я правильно понимаю, что мы ручками задаем идентификатор, а после указываем его в нужном месте в шаблоне определенной страницы в макросе %banners insert('идентификатор')% ?

Стоит присмотреть параметры баннера, например: время начала показа.

Еще вопрос про расположение баннера в шаблоне (в модуле есть специальная вкладка). Я правильно понимаю, что мы ручками задаем идентификатор, а после указываем его в нужном месте в шаблоне определенной страницы в макросе %banners insert('идентификатор')% ?

Да именно так. Еще стоит воздержаться от идентификатора в кириллице и ограничиться латиницей.

*

Cubes

  • *
  • 13
  • +0/-0
    • Просмотр профиля
Re:Не добавляются баннеры
« Ответ #2 : 26 Февраля 2015, 09:09:24 »
Не поверите, но причина оказалась в Adblock. Так как этот плагин "умный", он блокирует все со словами реклама и баннеры, поэтому в админке у меня ничего не добавлялось и не отображалось. Вот такие дела)