Курс 2016 года “Разработка на UMI.CMS от 0 до готового сайта”
запрос SQL, как выбрать товары в заданной категории

Автор KTIРаздел Макросы UMI.CMS

Ответов: 1
Просмотров: 3425
Последний ответ 23 Апреля 2012, 15:33:34
от KTI
Макрос отправляемый запрос на сторонний сервер

Автор fantom103Раздел Макросы UMI.CMS

Ответов: 2
Просмотров: 1673
Последний ответ 16 Июня 2013, 13:42:30
от fantom103
Не кешировать определенный запрос

Автор andreyРаздел Настройка системы и модулей

Ответов: 1
Просмотров: 1029
Последний ответ 08 Июня 2014, 22:03:55
от ilyar
Помогите сделать sql запрос!

Автор muldyРаздел Макросы UMI.CMS

Ответов: 1
Просмотров: 533
Последний ответ 01 Августа 2015, 10:46:48
от e.ioffe

0 Пользователей и 1 Гость просматривают эту тему.

*

niakriss

  • ***
  • 190
  • +2/-0
    • Просмотр профиля
запрос GET
« : 10 Октября 2012, 17:33:06 »
Не знала в какой раздел писать, но решила сюда отписаться...
вот у меня возник вопрос... почему на станице новостной ленты, если в адресной строке я припишу к примеру ?year=2012&month=10&day=5 то все новости нормально выводятся. только за это число.
а в блоге так не делается... почему?

*

Rodogor

  • ***
  • 189
  • +24/-0
    • Просмотр профиля
Re:запрос GET
« Ответ #1 : 11 Октября 2012, 13:25:41 »
Если я не ошибаюсь, то в макросах модуля news всегда идёт праверка на наличие этих параметров.
$month = (int) getRequest('month');
$year = (int) getRequest('year');
$day = (int) getRequest('day');
Далее проверяется пустой ли этот параметр или нет, если не пустой - то какие-то действия выполняются.
В модуле blogs20 такого нет.
"Нормально выводятся только за это число" - а как надо выводить, как выводится ?... :)

*

niakriss

  • ***
  • 190
  • +2/-0
    • Просмотр профиля
Re:запрос GET
« Ответ #2 : 12 Октября 2012, 09:48:36 »
оо... ограменное спасибо)) терь разобралась)) все заработало как надо)))